Home > Browsers support

The following recommended browsers will improve your experience using OTIS and ensure access to the activities and tools in your OTIS courses. If you do not use a browser listed on this page, OTIS may still work but some functionality may be lost.

Supported browsers include:

Internet Explorer

Version 9 or above

Firefox

Version 25 or above

Chrome

Version 30 or above

Safari

Version 6 or above

What browser & version am I using?

You can determine which browser & version you are using by going to http://www.whatsmybrowser.org/

How do I upgrade my browser?

Internet Explorer

If you have an unsupported version you can update it manually.

Firefox

Firefox is usually set to update automatically, however if you have an old version you can update it manually.

Chrome

Chrome is usually set to update automatically, however if you have an old version you can update it manually.

Safari

You can keep Safari up to date by updating your mac operating system.

SA Health Computers

If you are accessing OTIS from a SA Health computer using an unsupported browser, check to see if you have a alternate supported browser installed. If you do not have an alternative supported browser available, eHealth Systems can assist in upgrading to a supported version.

Known Issues

Internet Explorer 8 and below

Internet Explorer 8 and below have significant known issues with uploading files and accessing content within courses. For these reasons Internet Explorer 8 and below are not supported.

If you are unable to upgrade to Internet Explorer 9 or above you can use an alternative browser such as Chrome (which is installed on SA Health computers by default) or Firefox.

Internet Explorer 9

Drag-and-drop upload of content from outside the browser into OTIS requires Internet Explorer 10. Internet Explorer 9 users will still be able to upload content, but will not be able to use the drag-and-drop feature.